CISCO Switch Commands

Show Commands

show version
show boot 
show running-config
show ip interface
show file system
show ip int brief | excl unassigned
dir
cd

Configure IP

enable
configure t
interface vlan1
ip address 192.168.11.200 255.255.255.0
no shutdown

Upgrade

Method 1, copy tar file and extract tar file

copy tftp://192.168.11.1/c2960c405-universalk9-tar.150-2.SE.tar c2960c405-universalk9-tar.150-2.SE.tar
verify /md5 flash:/c2960c405-universalk9-tar.150-2.SE.tar
config terminal
boot system flash:/c2960c405-universalk9-mz.150-2.SE/c2960c405-universalk9-mz.150-2.SE.bin

Method 2, use archive commands which works with tar archive

archive download-sw  /leave-old-sw /reload  tftp://192.168.11.1/c2960c405-universalk9-tar.150-2.SE.tar

Method 3, bin file upgrade

copy tftp://192.168.11.1/c3560c405ex-universalk9-mz.150-2.SE.bin c3560c405ex-universalk9-mz.150-2.SE.bin
config terminal
boot system flash:c3560c405ex-universalk9-mz.150-2.SE.bin

Other commands

?
copy ?
delete /force /recursive c2960c405-universalk9-mz.150-2.SE

copy system:running-config tftp://192.168.11.1/running-config

copy nvram:startup-config tftp://192.168.11.1/startup-config

copy running-config startup-config

show ip int brief | excl unassigned

vlan


config t
interface vlan303
 ip address dhcp
end

##wan
interface GigabitEthernet0/10
switchport access vlan 303
 switchport mode access
 no cdp enable
 spanning-tree portfast
 spanning-tree bpdufilter enable

##lan
interface GigabitEthernet 0/5
switchport access vlan 303
 switchport mode access

2 comments:

Unknown said...

Thanks for this list of commands. Im so happy to find it on your blog coz I was having a hard time searching these list on google. Thanks again!

used cisco

rain said...

You are welcome. I am glad that you find it useful.